Seguridad

Lenovo parchea fallos críticos de seguridad que afectan a los conjuntos de chips de Broadcom en docenas de Lenovo ThinkPad

Según un aviso de seguridad emitido por Lenovo, dos vulnerabilidades críticas en los chipsets de Broadcom afectan al menos a 25 modelos de Lenovo ThinkPad.

Lenovo parchea fallos críticos de seguridad que afectan a los conjuntos de chips de Broadcom en docenas de Lenovo ThinkPad

Los modelos afectados son ThinkPad 10, ThinkPad L460, ThinkPad P50s, ThinkPad T460, ThinkPad T460p, ThinkPad T460s, ThinkPad T560, ThinkPad X260 y ThinkPad Yoga 260.

Uno de los defectos fue descubierto en junio por Google que lo reveló públicamente en septiembre. Google también publicó un exploit de prueba de concepto para una vulnerabilidad de firmware de Wi-Fi que afecta los chipsets de Broadcom en iOS 10 y anteriores.

El error detectado como CVE-2017-11120 es una vulnerabilidad de corrupción de memoria que los atacantes podrían aprovechar para ejecutar código y establecer una puerta trasera en un dispositivo de destino.

El fallo de seguridad reportado afectaba inicialmente a los conjuntos de chips Broadcom específicos utilizados en los iPhones de Apple, Apple TV y dispositivos Android fue reparada en el mismo mes.

La vulnerabilidad, rastreada como CVE-2017-11120, es una vulnerabilidad de corrupción de memoria, Apple lo abordó en la actualización de seguridad para el lanzamiento de iOS 11.

Ahora, Lenovo advierte de la presencia del defecto en dos docenas de modelos ThinkPad que utilizan el controlador de LAN inalámbrico BCM4356 de Broadcom para Windows 10.

Los chipsets Broadcom Wi-Fi utilizados por los dispositivos ThinkPad de Lenovo se ven afectados por la falla CVE-2017-11120 y también por la vulnerabilidad CVE-2017-11121, ambos son calificados como "críticos" y recibieron una calificación CVSS 10.

"Broadcom ha emitido un aviso para ciertos controladores Broadcom WiFi utilizados por muchos fabricantes de computadoras y dispositivos, que contienen vulnerabilidades de desbordamiento de búfer en el adaptador (no en la CPU del sistema)", dice el aviso de seguridad. "Broadcom inicialmente no tenía previsto solucionar estos problemas , pero cuando también surgió el problema WPA2 KRACK, Broadcom combinó ambas correcciones en un solo conjunto de actualizaciones de controladores. Lenovo recibió el primero de ellos a fines de 2017 y continúa lanzando correcciones a medida que se completan la integración y las pruebas".

Los fallos de seguridad pueden ser explotadas por atacantes remotos para ejecutar código arbitrario en el adaptador (no en la CPU del sistema) del sistema objetivo.

La vulnerabilidad CVE-2017-11121 también fue descubierta por expertos de Google, se trata de una vulnerabilidad de desbordamiento de búfer causada por una validación incorrecta de las señales de Wi-Fi.

Fuente: CVE-2017-11121

0 Comentarios 0 Comentarios
0 Comentarios 0 Comentarios